google.loadのjsapiでjQueryの読み込みはダメ

google.loadのjsapiでjQueryの読み込みはダメ

最新のjQueryが読み込めない

google.loadのjsapiでjQueryを読み込めるのはバージョン1.7.1までとなっており、そのあとにリリースされたバージョンのjQueryは読み込むことはできない。

例えば下記のようにgoogle.load(“jquery”, 1)と記述した場合は2014年7月時点で最新の1.11.1ではなく1.7.1を読み込んでしまう。

<script src="http://www.google.com/jsapi"></script>
<script>google.load("jquery", 1);</script>

google.load(“jquery”, 1.8)などと1.8以降のバージョンを指定した場合はjQuery自体を読み込むことができない。

jQueryを読み込む場合はajax.googleapis.comから読み込む。

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>

現在jQuery google 読み込みで検索すると検索結果の3番目にgoogle.loadの読み込み方法が表示されるためこの方法でjQueryを読み込まないように注意喚起のため記事を投稿。